Страница 1 из 1

radius moves mixed in with arc moves

СообщениеДобавлено: 13 апр 2016, 19:37
badger
I am getting some G02 and G03 radius moves mixed in with G02 and G03 arc moves with I and J coordinates. (I have no idea if this is the correct way to state this) I am using Inkscape 0.91 r13725 with the tangent knife tool and have experienced this on multiple computers. I am using LinuxCNC as my controller and it will not accept radius moves. Sample of mischievous gcode:

G02 X 107.2065 Y 254.0295 Z -1.0000 I 15.5537 J -317.9745 A -0.0137
G01 A -0.0137
G03 X 127.1334 Y 254.0002 Z -1.0000 I 11.1545 J 812.6277 A 0.0108
G01 A 0.0002
G02 X 293.9692 Y 253.9965 Z -1.0000 R414622.516611 A -0.0002
G01 A -0.0002
G03 X 460.8038 Y 254.0300 Z -1.0000 R196642.711048 A 0.0006
G01 A 0.0409
G03 X 466.6709 Y 254.9532 Z -1.0000 I -1.0573 J 25.8248 A 0.2712
G01 A 0.2712
G03 X 471.1143 Y 259.1277 Z -1.0000 I -1.7585 J 6.3238 A 1.2372

These are fairly straight line segments giving me the problem. In Inkscape if I delete between the two nodes, and then join between nodes I get a straight line segment that will be a straight G01 move. Another option is to add a few nodes to the line segment which makes more, shorter segments which don't seem to trigger the Radius code but use the proper "I" & "J" codes. The easier fix is to open up the .ngc file in notepad ++, search for "R" and then delete the "R" and "A" part of the line and then change either G02 or G03 to G01. This doesn't add much time but is an extra step.

Is there some tolerance setting in either Inkscape or Gcodetools that can be tweaked to prevent this?

Re: radius moves mixed in with arc moves

СообщениеДобавлено: 19 июл 2016, 16:19
badger
The problem seems to go away if I set the "Biarc Interpolation tolerance:" to " :good: 0.001". I had been using a value of "1" which provided sufficient accuracy for my RubBot and possibly reduced the number of segments. Live and learn.